re = /^(?:[\s\S]*)?(?:(?:"([\s\S]+)")|(?:'([\s\S]+)'))(?:[\s\S]*)?(?:(?:"([\s\S]+)")|(?:'([\s\S]+)'))(?:[\s\S]+)?$/
str = '\'Two\' \'singles\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end