$re = '/.+(?<!\/)/m';
$str = 'a1bc/
a1bc
http://compras.dados.gov.br/materiais/v1/materiais.html?pdm=08275/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);