re = /.+(?<!\/)/m
str = 'a1bc/
a1bc
http://compras.dados.gov.br/materiais/v1/materiais.html?pdm=08275/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end