package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)".*"`)
var str = `"hi mom" and "hi son"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}