$re = '/".*"/m';
$str = '"hi mom" and "hi son"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);