#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[一-龠]{3})特許"
Local $sString = "東京特許許可局" & @CRLF & _
"東京特許許諾" & @CRLF & _
"北海道特許許可局" & @CRLF & _
"神奈川特許許可局" & @CRLF & _
"さいたま特許許可局"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")