const regex = /(?<=[一-龠]{3})特許/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[一-龠]{3})特許', 'gm')
const str = `東京特許許可局
東京特許許諾
北海道特許許可局
神奈川特許許可局
さいたま特許許可局`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}