$re = '/\s*\b\d+\b\s*/';
$str = '28 VA288 298';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;