package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:\*|(GET|POST|PUT|PATCH|OPTIONS|HEAD|DELETE|ANY) (\/\S*))$`)
var str = `ANY /
ANY /{proxy+}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}