re = /^(?:\*|(GET|POST|PUT|PATCH|OPTIONS|HEAD|DELETE|ANY) (\/\S*))$/im
str = 'ANY /
ANY /{proxy+}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end