using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0{3})(?!6{3})[0-8]\d{2}-(?!0{2})\d{2}-(?!0{4})\d{4}$";
string input = @"762-37-6334
429-08-8462
519-75-9429
117-08-6495
544-12-9823
841-01-5655
494-82-9724
568-11-2312
420-42-8078
396-09-7229
869-57-0924
609-44-0934
578-20-1520
835-87-3325
636-03-4578
482-19-1418
364-60-1676
780-23-8549
265-33-9416
221-88-6838
550-13-2720
336-93-2610
193-47-3307
480-82-8373
750-66-0817
122-68-3192
673-84-7164
191-03-8274
412-41-9768
888-21-9775
805-53-9154
150-26-0934
880-42-1378
853-41-1922
467-22-3453
220-91-4157
657-24-3167
229-17-5111
411-38-6337
453-61-4836
123-27-0915
105-56-0050
646-82-7847
105-17-8892
301-70-3833
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}