import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}[^\\/]+";
final String string = "$ cat file1\n"
+ "0775 web:web /path/to/001\n"
+ "0775 web:web /path/to/foo\n"
+ "0775 web:web /path/to/bar\n"
+ "0775 web:web /path/to/baz\n"
+ "0775 web:web /path/to/hello\n"
+ "$ cat file2\n"
+ "0755 web:web /path/to/foo\n"
+ "0755 web:web /path/to/bar\n"
+ "0755 web:web /path/to/baz\n"
+ "$ diff -y file1 file2\n"
+ "0775 web:web /path/to/001 | 0755 web:web /path/to/foo\n"
+ "0775 web:web /path/to/foo | 0755 web:web /path/to/bar\n"
+ "0775 web:web /path/to/bar | 0755 web:web /path/to/baz\n"
+ "0775 web:web /path/to/baz <\n"
+ "0775 web:web /path/to/hello <\n"
+ "# if you could ignore '^[^\\/]+' on each line\n"
+ "0775 web:web /path/to/001 <\n"
+ "0775 web:web /path/to/foo | 0755 web:web /path/to/foo\n"
+ "0775 web:web /path/to/bar | 0755 web:web /path/to/bar\n"
+ "0775 web:web /path/to/baz | 0755 web:web /path/to/baz\n"
+ "0775 web:web /path/to/hello <";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}