import re
regex = re.compile(r"\d{4}[^\/]+", flags=re.MULTILINE)
test_str = ("$ cat file1\n"
"0775 web:web /path/to/001\n"
"0775 web:web /path/to/foo\n"
"0775 web:web /path/to/bar\n"
"0775 web:web /path/to/baz\n"
"0775 web:web /path/to/hello\n"
"$ cat file2\n"
"0755 web:web /path/to/foo\n"
"0755 web:web /path/to/bar\n"
"0755 web:web /path/to/baz\n"
"$ diff -y file1 file2\n"
"0775 web:web /path/to/001 | 0755 web:web /path/to/foo\n"
"0775 web:web /path/to/foo | 0755 web:web /path/to/bar\n"
"0775 web:web /path/to/bar | 0755 web:web /path/to/baz\n"
"0775 web:web /path/to/baz <\n"
"0775 web:web /path/to/hello <\n"
"# if you could ignore '^[^\\/]+' on each line\n"
"0775 web:web /path/to/001 <\n"
"0775 web:web /path/to/foo | 0755 web:web /path/to/foo\n"
"0775 web:web /path/to/bar | 0755 web:web /path/to/bar\n"
"0775 web:web /path/to/baz | 0755 web:web /path/to/baz\n"
"0775 web:web /path/to/hello <")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")