$re = '/.*\h([a-zA-Z0-9]{8})$/m';
$str = 'Folder A\\Folder C\\File three.txt 56efd95f
Folder A\\File one.txt b8e1b873
Folder A\\Folder B\\Folder D\\File four.txt 56efd95f
Folder A\\Folder B\\File two.txt 21e8e9c9';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;