# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\h([a-zA-Z0-9]{8})$"
test_str = ("Folder A\\Folder C\\File three.txt 56efd95f\n"
"Folder A\\File one.txt b8e1b873\n"
"Folder A\\Folder B\\Folder D\\File four.txt 56efd95f\n"
"Folder A\\Folder B\\File two.txt 21e8e9c9")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.