$re = '/(\w+)::|(?:library|require|requireNamespace)\(\"?(\w+)\"?\)/m';
$str = 'capturethis::dontcapturethis
library(capturethis)
require(capturethis)
requireNamespace(capturethis)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);