re = /(\w+)::|(?:library|require|requireNamespace)\(\"?(\w+)\"?\)/m
str = 'capturethis::dontcapturethis
library(capturethis)
require(capturethis)
requireNamespace(capturethis)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end