using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-zA-Z])(?=.*[\d.@_-])[a-zA-Z\d.@_-]{6,40}$";
string input = @"0a123456789-.@_";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}