re = /^(?=.*[a-zA-Z])(?=.*[\d.@_-])[a-zA-Z\d.@_-]{6,40}$/
str = '0a123456789-.@_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end