package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^-]+`)
var str = `блаблабла
- блаблабла
- блаблабла
блаблабла
- блаблабла
- блаблабла
блаблабла`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}