$re = '~^[^-]+~m';
$str = 'блаблабла
- блаблабла
- блаблабла
блаблабла
- блаблабла
- блаблабла
блаблабла';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;