const regex = /<object[^>]*>.*?<\/object>|<span[^>]*>.*?<\/span>|<(?:object|embed|svg|img|div|span|p|a)[^>]*>|((\s|^)(\<3|<3|\<\/3|<\/3|\:'\)|\:'\-\)|\:D|\:\-D|\=D|\:\)|\:\-\)|\=\]|\=\)|\:\]|'\:\)|'\:\-\)|'\=\)|'\:D|'\:\-D|'\=D|\>\:\)|>\:\)|\>;\)|>;\)|\>\:\-\)|>\:\-\)|\>\=\)|>\=\)|;\)|;\-\)|\*\-\)|\*\)|;\-\]|;\]|;D|;\^\)|'\:\(|'\:\-\(|'\=\(|\:\*|\:\-\*|\=\*|\:\^\*|\>\:P|>\:P|X\-P|x\-p|\>\:\[|>\:\[|\:\-\(|\:\(|\:\-\[|\:\[|\=\(|\>\:\(|>\:\(|\>\:\-\(|>\:\-\(|\:@|\:'\(|\:'\-\(|;\(|;\-\(|\>\.\<|>\.<|D\:|\:\$|\=\$|#\-\)|#\)|%\-\)|%\)|X\)|X\-\)|\*\\0\/\*|\\0\/|\*\\O\/\*|\\O\/|O\:\-\)|0\:\-3|0\:3|0\:\-\)|0\:\)|0;\^\)|O\:\-\)|O\:\)|O;\-\)|O\=\)|0;\-\)|O\:\-3|O\:3|B\-\)|B\)|8\)|8\-\)|B\-D|8\-D|\-_\-|\-__\-|\-___\-|\>\:\\|>\:\\|\>\:\/|>\:\/|\:\-\/|\:\-\.|\:\/|\:\\|\=\/|\=\\|\:L|\=L|\:P|\:\-P|\=P|\:\-p|\:p|\=p|\:\-Þ|\:\-Þ|\:Þ|\:Þ|\:þ|\:þ|\:\-þ|\:\-þ|\:\-b|\:b|d\:|\:\-O|\:O|\:\-o|\:o|O_O|\>\:O|>\:O|\:\-X|\:X|\:\-#|\:#|\=X|\=x|\:x|\:\-x|\=#)(?=\s|$|[!,.?]))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<object[^>]*>.*?<\\\/object>|<span[^>]*>.*?<\\\/span>|<(?:object|embed|svg|img|div|span|p|a)[^>]*>|((\\s|^)(\\<3|<3|\\<\\\/3|<\\\/3|\\:\'\\)|\\:\'\\-\\)|\\:D|\\:\\-D|\\=D|\\:\\)|\\:\\-\\)|\\=\\]|\\=\\)|\\:\\]|\'\\:\\)|\'\\:\\-\\)|\'\\=\\)|\'\\:D|\'\\:\\-D|\'\\=D|\\>\\:\\)|>\\:\\)|\\>;\\)|>;\\)|\\>\\:\\-\\)|>\\:\\-\\)|\\>\\=\\)|>\\=\\)|;\\)|;\\-\\)|\\*\\-\\)|\\*\\)|;\\-\\]|;\\]|;D|;\\^\\)|\'\\:\\(|\'\\:\\-\\(|\'\\=\\(|\\:\\*|\\:\\-\\*|\\=\\*|\\:\\^\\*|\\>\\:P|>\\:P|X\\-P|x\\-p|\\>\\:\\[|>\\:\\[|\\:\\-\\(|\\:\\(|\\:\\-\\[|\\:\\[|\\=\\(|\\>\\:\\(|>\\:\\(|\\>\\:\\-\\(|>\\:\\-\\(|\\:@|\\:\'\\(|\\:\'\\-\\(|;\\(|;\\-\\(|\\>\\.\\<|>\\.<|D\\:|\\:\\$|\\=\\$|#\\-\\)|#\\)|%\\-\\)|%\\)|X\\)|X\\-\\)|\\*\\\\0\\\/\\*|\\\\0\\\/|\\*\\\\O\\\/\\*|\\\\O\\\/|O\\:\\-\\)|0\\:\\-3|0\\:3|0\\:\\-\\)|0\\:\\)|0;\\^\\)|O\\:\\-\\)|O\\:\\)|O;\\-\\)|O\\=\\)|0;\\-\\)|O\\:\\-3|O\\:3|B\\-\\)|B\\)|8\\)|8\\-\\)|B\\-D|8\\-D|\\-_\\-|\\-__\\-|\\-___\\-|\\>\\:\\\\|>\\:\\\\|\\>\\:\\\/|>\\:\\\/|\\:\\-\\\/|\\:\\-\\.|\\:\\\/|\\:\\\\|\\=\\\/|\\=\\\\|\\:L|\\=L|\\:P|\\:\\-P|\\=P|\\:\\-p|\\:p|\\=p|\\:\\-Þ|\\:\\-Þ|\\:Þ|\\:Þ|\\:þ|\\:þ|\\:\\-þ|\\:\\-þ|\\:\\-b|\\:b|d\\:|\\:\\-O|\\:O|\\:\\-o|\\:o|O_O|\\>\\:O|>\\:O|\\:\\-X|\\:X|\\:\\-#|\\:#|\\=X|\\=x|\\:x|\\:\\-x|\\=#)(?=\\s|$|[!,.?]))', 'g')
const str = `<p>:)</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}