const regex = /^(?!.*([^])(.*\1){3}]?)[$$[-^?!!.'''-*11{33}5577\\-]{57}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*([^])(.*\\1){3}]?)[$$[-^?!!.\'\'\'-*11{33}5577\\\\-]{57}$', '')
const str = `\\])(.37}\$]?)[\$^-1{3){3}}5]{5.*([^75'-'-*1(?!7\\\$['^?!*\\1!.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}