import Foundation
let pattern = #"^(?!.*([^])(.*\1){3}]?)[$$[-^?!!.'''-*11{33}5577\\-]{57}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"\])(.37}$]?)[$^-1{3){3}}5]{5.*([^75'-'-*1(?!7\$['^?!*\1!."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}