package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[1-5][0-9]{5,}|6(?:[1-4][0-9]{4,}|5(?:[1-4][0-9]{3,}|5(?:[1-2][0-9]{2,}|3(?:[1-5][0-9]{1,}|[6-9][0-9]*)|[4-9][0-9]{1,})|[6-9][0-9]{2,})|[6-9][0-9]{3,})|[7-9][0-9]{4,})`)
var str = `12
23
25
100
100000
123
65534
65536
67000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}