import re
regex = re.compile(r"(?:[1-5][0-9]{5,}|6(?:[1-4][0-9]{4,}|5(?:[1-4][0-9]{3,}|5(?:[1-2][0-9]{2,}|3(?:[1-5][0-9]{1,}|[6-9][0-9]*)|[4-9][0-9]{1,})|[6-9][0-9]{2,})|[6-9][0-9]{3,})|[7-9][0-9]{4,})", flags=re.MULTILINE)
test_str = ("12\n"
"23\n"
"25\n"
"100\n"
"100000\n"
"123\n"
"65534\n"
"65536\n"
"67000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")