import re
regex = re.compile(r"(?:<link[^>]+components/bitrix|(?:src|href)=\"/bitrix/(?:js|templates))", flags=re.MULTILINE)
test_str = ("src=\"/bitrix/templates/1c-bitrix-new/images/vlogo.png\"\n"
"src=\"/bitrix/templates/1c-bitrix-new/images/16.png\"\n"
"src=\"/bitrix/js/main/core/core_db.min.js?14328132264928\"\n"
"href=\"/bitrix/js/main/core/css/core_image.min.css?14293595955405\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")