re = /^\[.*\]\s\[(.*)\]\s\[(.*)\]\s\[(lmstat)\].*(?<!lmgrd)$/
str = '[thing] [stuff] [26009] [lmstat] SIMULIA Isight v2017 foobar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end