package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\d{4}-\d{2}-\d{2}`)
var str = `ejennsd 2022-07-28T03:00:00.000Z skdjkdc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}