using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]+(?:\s+[A-Z]+)*\b";
string input = @"There Are Many Options in KENTUCKY AREA
There Are Many Options in KENTUCKY,NEW YORK,ETC.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}