package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z]+(?:\s+[A-Z]+)*\b`)
var str = `There Are Many Options in KENTUCKY AREA
There Are Many Options in KENTUCKY,NEW YORK,ETC.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}