const regex = /(https\:\/\/cdn\.[a-zA-Z0-9`~!@#$%^&*,?;:=+-\.\/\-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https\\:\\\/\\\/cdn\\.[a-zA-Z0-9`~!@#$%^&*,?;:=+-\\.\\\/\\-]+)', 'gm')
const str = `RegExr was created by gskinner.com, and is proudly hosted by Media Temple.
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.
The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns.
Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English.
https://cdn.example.net/embed/%20Courses/1.%20After%20effects?expires=15911919&signature=e57d02a8f3f1971a6
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}