$re = '/(https\:\/\/cdn\.[a-zA-Z0-9`~!@#$%^&*,?;:=+-\.\/\-]+)/m';
$str = 'RegExr was created by gskinner.com, and is proudly hosted by Media Temple.
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.
The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns.
Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English.
https://cdn.example.net/embed/%20Courses/1.%20After%20effects?expires=15911919&signature=e57d02a8f3f1971a6
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);