re = /[a-z]+(\.|_)?([a-z0-9]+(\.|_)?)+?[a-z0-9]+@[a-z0-9]+_?[a-z0-9]+\.[a-z]+/
str = 'mohamed@yahoo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end