import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<fileName>[^.]+\\.(?:jpg|png|gif|pdf|xlx))(?:\\|(?:width=(?<width>.*?))?,?(?:height=(?<height>.*?))?)?$";
final String string = "img2.png|width=83.33333333333334%\n"
+ "robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400\n"
+ "abc.pdf|width=200\n"
+ "dfe.xlx\n"
+ "dfe.gif|height=400\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}