re = /^(?<fileName>[^.]+\.(?:jpg|png|gif|pdf|xlx))(?:\|(?:width=(?<width>.*?))?,?(?:height=(?<height>.*?))?)?$/m
str = 'img2.png|width=83.33333333333334%
robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400
abc.pdf|width=200
dfe.xlx
dfe.gif|height=400
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end