using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"By (\w+ \w+) \(@\w+\), *\w+ \w+ \[(.+)\]";
string input = @"By Patrick Traughber (@ptraughber), Product Manager [06:04 UTC]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}