$re = '/By (\w+ \w+) \(@\w+\), *\w+ \w+ \[(.+)\]/';
$str = 'By Patrick Traughber (@ptraughber), Product Manager [06:04 UTC]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);