import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+[.:]\\d+\\.\\d+\\.\\d+::[^:]*\\w$";
final String string = "This matches which is correct:\n\n"
+ "10.179.12.241::CALMGTVCSRM0210\n\n"
+ "This matches but should not:\n\n"
+ "10.179.12.241::CALMGTVCSRM0210:as";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}