const regex = /^\d+[.:]\d+\.\d+\.\d+::[^:]*\w$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+[.:]\\d+\\.\\d+\\.\\d+::[^:]*\\w$', 'gm')
const str = `This matches which is correct:
10.179.12.241::CALMGTVCSRM0210
This matches but should not:
10.179.12.241::CALMGTVCSRM0210:as`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}