$re = '/"{3}(?>(?<!\\\\"{3}).)+?"{3}/m';
$str = '"""asdasd"""
"""a"sda""sd"""
"""a"s"dasd"""
"""asdas"d"""
"""a""sd""a\\"""sd"""
"""asd\\"""a""sd"""
"""asd"""sdfsdf"""
"""a"sd"""sdfsdf"""s""df"""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);