package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1]\d{3}`)
var str = `1000
1001
1002
1003
1004`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}