$re = '/[1]\d{3}/m';
$str = '1000
1001
1002
1003
1004';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);