$re = '/^(?<group>[^\{\}]*)?\{|(?<T>([\w\s]+)\{(?<var>[\w\s]+)=(?<val>[\d\s]+)[;\s]+\})/im';
$str = 'group A { T1 { X = 44; }
T2 { Y = 33; } } ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);