import re
regex = re.compile(r"^(?<group>[^\{\}]*)?\{|(?<T>([\w\s]+)\{(?<var>[\w\s]+)=(?<val>[\d\s]+)[;\s]+\})", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("group A { T1 { X = 44; }\n"
" T2 { Y = 33; } } ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")