package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*cn=(\w+)`)
var str = `ou=company\ou=country\ou=site\cn=office\cn=name\ou=pet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}