re = /^.*cn=(\w+)/
str = 'ou=company\\ou=country\\ou=site\\cn=office\\cn=name\\ou=pet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end