package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("[\s\S]*?(.*)")|('[\s\S]*?(.*)')`)
var str = `qui(" ugi
kjb j
", ccc, quo('bbb', xxx))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}