re = /("[\s\S]*?(.*)")|('[\s\S]*?(.*)')/m
str = 'qui(" ugi
kjb j
", ccc, quo(\'bbb\', xxx))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end