const regex = /(?:(?=(.*?([a-z]))(?!.*\2))\1){26}/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?=(.*?([a-z]))(?!.*\\2))\\1){26}', 'ig')
const str = `The quick brown fox jumps over a lazy dog.
Watch "Jeopardy!", Alex Trebek's fun TV quiz game.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}